Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / is knut working for anybody anymore?
« Last post by jinknutsupport on November 25, 2016, 06:02:44 pm »
Mine have stopped working. Curious if there's anybody out there that still has a functioning unit.
2
Setting Up Knut / Re-setting up in 2016 is impossible?
« Last post by jinknutsupport on November 19, 2016, 09:55:04 pm »
Hey all,

Is anybody able to reset their device and run through the setup in 2016?  I've tried it with two units, and failed with both.

What am i doing? Take out a battery, press and hold the reset button while putting the battery back.    Keep holding the button,  until the light starts flashing like crazy, then release.  Then connect to 'Knut Setup' wifi.   Up until this point, everything works fine.  But when I next try and connect to 169.254.1.1 , it fails -> browser complains about not being able to connect. I tried in Safari and in chrome.

I've come to rely on the knut so this is a downer!
3
General Discussion / Re: Is tghis not supported anymore.
« Last post by norbs on June 25, 2016, 01:31:33 am »
Support has never been great. Pity, they are interesting little gadgets.

Maybe a coincidence, but both my Knuts stopped working on the 23rd June.

Hard resets do nothing. Can not connect to either. In the bin they go. :(
4
General Discussion / Re: Is tghis not supported anymore.
« Last post by jinknutsupport on April 04, 2016, 06:05:48 pm »
Hey guys, any news you can share with us?  Noticed it's been radio silence for quite some time now. Thanks!
5
Setting Up Knut / Re: command-line compiler?
« Last post by jinknutsupport on December 17, 2015, 12:08:37 pm »
Also of note, although i guess it doesn't matter, I noticed that you can get garbage showing up in your freespace buffer. First compile a large rule/program, let it update, then compile a shorter rule/program.  Remainder of the old rule/program remains in the config file (doesn't zero out, unused buffer), but again may not matter as nobody/nothing should be reading from that area.
6
Setting Up Knut / command-line compiler?
« Last post by jinknutsupport on December 10, 2015, 10:25:05 pm »
Hi there, i know this is a long shot, but any chance you could post a command line compiler for knut advanced rules? 

I noticed that there appears to be a bug in iOS app for the compiler.  Per your suggestion, I programatically removed a internal knut temp sensors from the device config, which gives me an extra 40 bytes.  (and the client reports that extra 40 bytes available space)  Unfortunately, if I compile in the client app, a program that eats even a single byte into that now empty space, the app just immediately crashes when i compile.  I'm guessing this is just a simple bug in the iOS app and not the compiler itself.  (perhaps hard coded buffer size?)

So, either iOS code, or command line would be suuuuper useful.  :-)  Best of luck with Water in the meantime!

Cheers

7
Setting Up Knut / Re: difficulties in getting up to date readings?
« Last post by jinknutsupport on December 10, 2015, 10:06:55 pm »
Well for now, I'm just going to archive the data and start with a clean slate in that account.   But just a heads up, there appears to be some sort of client app bug here.
8
Setting Up Knut / (re)Calibrating external temperature sensors
« Last post by jinknutsupport on December 09, 2015, 09:06:02 pm »
Hi All,

Has anybody had luck in manually calibrating the sensors? In the iOS app (and I assume android), if you go to device settings / sensors / your-temp-sensor-name, you can adjust 'calibration M' and 'calibration B'.  I read somewhere on the site that M represents the slope, and that B represents the 'intersect'.  Not 100% sure what that means.

For me, I now have a sensor that seems to be consistently half a degree too cold. I think 'b' from above, is this fudge factor variable that I would want to mess with to fix that.  Unfortunately, i don't see any change at all when I mess with these values.  Whether i put 0.5, 5, 50, 500, 5000.  The readings appear to be unaffected.   

Am I doing something wrong? Any tips?
Cheers
9
Setting Up Knut / Re: difficulties in getting up to date readings?
« Last post by jinknutsupport on December 06, 2015, 04:25:13 pm »
This appears to be a problem iOS and Android clients. 

Notifications and data values are being sent out by the knut and do appear in the email account, but clients can't connect.  This morning I reset the knut to default setup (nothing plugged in), but clients still complains about missing imap folder. As far as i can tell, the appropriate imap/gmail labels are all there.

Then i reset the knut again, but using a different gmail address - it immediately started working.

I do have 178,956 data emails sitting in the (now) non-functional account.  (for the most part, each with 2 sets of readings)  Is it possible that this the client code is choking on that?  Any suggestions on other things I should check/try in my gmail account, or in the client apps?

Any feedback would be very much appreciated.
10
Setting Up Knut / Re: difficulties in getting up to date readings?
« Last post by jinknutsupport on December 06, 2015, 01:14:01 am »
Hmm, the newly setup one is near identical to the old one, but ios/android clients are able to fetch data from the new one, and still complain about "IMAP data folder missing. Can't fetch data" from the old one.   This despite the fact that if I login to gmail webpage, I can see the imap folder, and that data is indeed being uploaded every x minutes as expected. But clients don't be able to see it. 

I'll try resetting the 'old' knut and doing the whole the setup from scratch on the old device to see if anything changes.
 


Pages: [1] 2 3 ... 10